HTC Sense 3.0 Only for New HTC Devices with Correct Hardware Config


HTC Sense 3.0 Only for New HTC Devices with Correct Hardware Config

When it comes to technology, catching up to it is always the hardest. In HTC's case, they've showcased a swanky new interface, via HTC Sense 3.0 on the HTC Sensation that was recently announced. Unfortunately, the company has also said that the newly improved interface is solely for its new range of devices such as the HTC Flyer, Sensation and Evo 3D due to hardware requirements.

GSM Arena - It turns out that the new Sense UI 3.0, showcased on the HTC Sensation a couple of days back won't be supported by older HTC devices, due to hardware limitations. This would really create a serious software gap between the older and newer generation of HTC Androids and the recently released Desire S and Incredible S are on the bad side this time.

While HTC did not specifically state what the hardware requirement is, this statement would indicate that the earlier generation of HTC devices will be left behind, some of which are the recently launched HTC Incredible S and HTC Desire S. So if you're hoping to get a taste of the new HTC Sense 3.0, you might want to hold out a bit more.

For the full story, click here.

All News Categories

News for Past 12 Months

Subscribe to HWZ Here!

Subscribe now to receive latest tech news, articles and promotions straight to your inbox!
 
 
By signing up, you indicate that you have read and agreed to the and .